Bite my bytes

What I learn by day I blog at night - A blog from Microsoft Consultant working from Ljubljana, Slovenia

  Home :: Contact :: Syndication  
  999 Posts :: 7691 Comments :: 235 Trackbacks

Search

Most popular posts
in last 360 days

Categories

My Projects

Archives

Stuff


Copyright © by David Vidmar
 
Contact me!
 
LinkedIn Profile
 
 
 

I recorded a presentation I gave with Camtasia, and when I wanted to show it to some folks, just copying the files Camtasia produces to IIS7 didn’t work.

The Camtasia Flash player displayed ok, but video didn’t start. I also noticed that “File Info” feature in Flash player reported file size zero.  Linking directly to .mp4 file return error 404 – file not found.

image

Of course – mp4 mime type is missing! By default IIS has mime types for extensions .mp2 and .mp3, just add one and everything works again!

image

Posted on Monday, February 02, 2009 9:24 AM | |

Feedback

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 3/24/2009 11:45 PM christine
Worked like a charm! thanks!

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 6/17/2009 6:33 AM vardhani
I loaded a camtasia video to my website. the first page appears when i click on play i can see only the control bar nothing further .. a blank screen ... please help..asap

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 8/12/2009 7:51 PM Bela
Thank you so much - after trying many different things, it turns out that this indeed was what I needed for the video to work!

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 11/20/2009 2:36 AM Dmitriy Zasyatkin
Thank you so much for posting this. Its exactly the problem that we were having and I knew that it must have been an IIS7 file type issue, but this made it really easy to fix.

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 12/2/2009 8:52 PM nlindley
same problem with IIS 7.5 . thanks!!

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 1/1/2010 1:36 AM Rashid KAZI
Great... thank you so much.

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 maç oyunları maç oyunu 1/27/2010 12:00 PM Maç Oyunları Maç Oyunu
Thank you so much for posting this.Great...

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 1/30/2010 1:24 PM Erkek Oyunları Erkek Oyunu
Good work. Thanks...

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 2/5/2010 4:01 PM nate
BINGO! This is still needed to .swf files as well, not just mp4 files...thanks!

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 2/10/2010 1:50 PM Korku Oyunları
Great. Thanks...

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 2/10/2010 1:53 PM yarış oyunları
Thank you so much after trying many different things..

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 2/10/2010 1:55 PM kız oyunu
Its exactly the problem that we were having and I knew that it must have been an IIS7 file type issue, but this made it really easy to fix. Thanks...

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 2/10/2010 1:56 PM ev oyunları
Thank you so much for posting this..

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 2/10/2010 1:58 PM Barbie Oyunu
I think it is very successful. Keep on work. Thanks...

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 2/15/2010 11:05 AM Savaş Oyunu
Amazing, super..

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 2/15/2010 11:12 AM çocuk oyunu
Thanks...Great..

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 3/31/2010 10:59 PM Damian
Yeeeeeeeees. Now work.

Thanks !

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 11/3/2010 5:55 PM M
Fantastic - thanks!!

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 11/16/2010 7:25 PM Dave
YEEEE!!!! HAAAAA!!!! This made my day!!

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 3/26/2011 10:57 AM Rick
WOW A POST THAT JUST KEEPS ON HELPING, thanks you so much !!

# re: Camtasia video not playing in Flash on IIS7 / Windows Server 2008 10/18/2011 3:33 PM Ba Nyar Thein
That's really great and helpful answer. You are guru. Thank you sooooo much man.....

Comments have been closed on this topic.